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Wireframing using InDesign

Indesign®

Whilst not exactly the first application that comes to mind when you are making
a wireframe, InDesign is a great tool for doing exactly that. There are four basic
features that enable you to make wireframes in InDesign.

Masters

Masters are templates that you can user throughout your document. Use them
to define the outline of your document. They should contain elements that are on
each and every page, such as page numbers or the outline of your wireframe.
Things that belong in the Master are typically found in the same place with the
same design on every page.

Paragraph Styles

Like HTML and CSS we can define certain styles and apply them throughout the
document, to keep things consistent but also to change a lot of things all at once.
| encourage you to always define paragraph styles, it saves a lot of time in the
long run.

Nested Documents

A powerful feature of InDesign, enabling us to design commonly used elements
and nest them inside our Interaction Design Document so that we can edit them
all at once. The best use of nested documents are for elements with the same
design but located on different places and not on every page.

Libraries

Libraries make life a lot easier for us since we can download a library with
commonly used elements such as icons or cursors and re-use them throughout
our document. You can best use libraries for more detailed elements such as
icons.

The Basics

Before we start we need to get the basics done. To make a new Interaction
Design Document in InDesign:

Click File > New > New Document

Make sure you select A4 size, have the correct Orientation and that Facing
Pages is not turned on.
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Mew Document
Docurnent Preset: [Default] -
Number of Pages: [ [ Facing Pages Reset
DMaster Text Frame
Save Preset...
Page Size: A4
Maore Options
Width: 7210 mm Orientation: =
Height: =297 mm
Colurmns
Number: |51 Gutter: %] 4,233 mm
Margins
Top: £|12,7 mm Left: £/12,7 mm
Bottom: 512,7 mm Right: 1£/12,7 mm

Now that we have a new document it is time to set it up a bit.
Click the Window > Pages and select the A-Master

The A-Master should contain the basic structure for most of the pages of your
Interaction Design Document. It is an important page and it is important that you
define what you want to have in it. For our purposes we want a title and a page
number text box. To achieve this, we select the Type Tool (located in the left
panel) and drag a text box big enough to contain our page titles.

For our page number we do exactly the same thing. Take note of the blue lines
around the text boxes: they are dotted, indicating that they are in the Master.

To get an automatic page number on each page, select the Type Tool and click
on the text box where you want your page number to appear. You should see the
blinking cursor.

Go to Type > Insert Special Character > Markers > Current Page Number

You should see that the text box has been filled with a character, in this case an
A, indicating the page we are one namely the A-Master.

To see page numbers in action once again go to your Pages (Window > Pages)
and double click the first page. Please note: we are not working with Masters
anymore; we are on the canvas.

If you have done it correctly, you should see that the page you selected has a 1
in the corner, indicating the page number.
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Let’s go back to our Master again and by double clicking the
A-Master in the Pages palette.

Effects

With the Type Tool selected, selected the page number (in our case
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You should see the Paragraph style palette appear. Click the New
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53 Table Styles

|

B Table

Paragraph Style and right click the new Paragraph Style and
then we can proceed to edit it. Make sure however that your page
number is still selected on the A-Master.

Cell Styles

Now we are seeing the Paragraph Style Options dialogue box. Here
we can define our Style Name (Page Number), Font Family, Size,
etc. Play around a little until you find the right font and size. With the
Preview Button ticked you can see you changes as you make them.

Now we are going to define the Default Paragraph Style for our page titles.
Create a new Paragraph Style, go to the Paragraph Style Options of that style
(make sure your page number is deselected) and make a Paragraph style that
would be good for titles.

When you have done that, and selected OK, click inside the text box (with the
Type Tool selected) that we want to use for our page titles and then click our
newly created Paragraph Styles. What this had done is make sure that all the text
inside that particular text box will have that style applied to it.

When we go to the canvas and select the first page, we can add text to the title
text box. CTRL + SHIFT + Click (Windows) or CMD + Shift + Click (Mac) the
title box. This will “lift” it up from out of the Master and make it editable. Whatever
you do though, do not move it around at all. This will remove it completely from
the Master and will result in you not being able to edit it in the Master and have
the changes reflect in all your pages.

You should be able to type a page title now, and if everything has been done
correctly, the paragraph style we defined earlier should be applied automatically.
If that is not the case, simply go back to your A-Master, click the text box with the
Type Tool selected and select the appropriate paragraph style.
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Paragraph Style Options

General - Style Name: |Page_Titles

Lot

Adwanced Character Formats Basic Character Formats

Indents and Spacing

Tabs Font Family:  Arial -

Paragraph Rules

Keep Options Font Style: Regular -

Hyphenation Size:  pEEN - Leading: (28,8 pt) -
Justification Kerning: Metri TR

Drop Caps 2nd Nesied Styles Kerning: Metrics - Tracking: 0 -
Bullets and Numbering Case: MNormal v Position: Mormal v
Character Color

OpenType Features

Undesiing Opions [T] underline Ligatures [CIno Break
Strikethrough Optians [T] strikethrough
[¥] preview ( oK ] [ cancel |
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Another Master

We have seen how to make Paragraph Styles and Masters but now it is time
that we start doing some wireframing. To start off, let us build another Master.
This is done by right-clicking in the Pages palette, above the divider between the
Masters and the Pages and select New Master. Make sure your new Master is
based on the A-Master.

New Master

prefix: 8
Name: |Master [W]
Based on Master: [Mone] H

Number of Pages: LMonel

You should see a new Master Page appear that looks identical to your A-Master.
This is because it is based on the A-Master and the B-Master has effectively
been layered on top of the A-Master.

With the B-Master selected we can draw the outlines of our wireframe (for our
purposes a mobile device), with the Rectangle Tool, located on the panel on the
left.

With that done we will go and apply this new B-Master on the first page of our
canvas. This is done by dragging your B-Master onto your first page. Or any page
for that matter.

The beauty of this is that you can now simply drag our Master onto any other
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pages that require the outline of the wireframe. We can also go back to the
Master and edit the wireframe to add or remove elements that reapear in every

screen, which saves a lot of time.

To see this in action, let’s edit the B-Master by adding a bar at the top of our
mobile application screen and a menu at the bottom, with some labels. Once
again, take note of the dotted lines: this indicates that you are working with an
element that is part of a Master or that you are inside a Master. When making the

labels for your menu items, make sure to apply paragraph styles to them.

You should see the changes made in the B-Master reflected on the first page.
Changes made to your A-Master will be seen on your B-Master and all the

pages with a the B- or A-Master applied.

To add new pages to your document, simply click the Add New Page button on
your Pages palette. For us it should contain the B-Master template but you can
also just drag your A-Master on top of it to apply a different master.

Screen 1
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Nested Documents

By now we should have a few paragraph styles defined and some basic

wireframe. Next we are going to use a really simple but powerful feature of
InDesign and that is the ability to nest documents. For this we open a new

document, in this case the size does not matter.

[Non=] |:|
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File > New > New Document

Mew
Edit
Send
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Next we are going to make a menu that will be used by us frequently
throughout the application, the Contacts Menu. The same rules apply:
make use of paragraph styles once again. Save this document and give
it a name that is consistent with whatever naming scheme you want
use, for Instance e01, or Element01.

Close this newly created document. Now locate it on your computer and
drag it inside your Interaction Design Document. You will notice that this newly
created element, once dragged onto your canvas, is quite large. Simply resize it
and put it where the Contacts menu should be located. Once created and inside
your document we can always edit the original. We can do this by right clicking
the element and selecting Edit Original.

If, for instance, you decide that each and every contacts menu should not have
the menu label Edit but Delete instead, you can achieve this quite easily by
editing the original. In e01, make your changes and close the document. You
should see these changes reflected in your original document containing the
element. Nested elements can be viewed by clicking Window > Links. This
gives us an overview of all of the elements we nested inside our document.

Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Paste Into Alt+Ctrl+V
Paste in Place Alt+Shift+Ctrl+V
Zoom +
Transform +
Transform Again »
q 0
Select 3
New
C =dit Leck Position Ctrl+L
S?n d Stroke Weight »
Start : Contacts .
P L LA Fitting 4
Effects 3
Object Layer Options... LJ
Graphics 3
Edit Criginal
Interactive +
Tag Frame 3
Autotag
Display Performance 3
~ B Bl @ Open [ InCopy 2
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Libraries

We have created external documents, nested them inside our Interaction Design
Document, created Paragraph styles and seen how Masters work. Now we can
take a look at Libraries. They can be very powerful in saving you a lot of time
while creating wireframes and there are a lot of them available for download.
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Big Picture

Go to http://tinyurl.com/34j5fd and download
the library wireframe_elements.indl. Once
downloaded , double click it and it will open up
in InDesign.

These libaries usually contain common objects,
such as icons, symbols, etc. They save you
time, so you don’t have to create these icons
yourself. To see them in action, we will once
again go to our B-Master and drag the mobile
phone icon onto our status bar.

Once again, if done correctly, this element will
appear on the first page of our document, with a
dotted outline, indicating it’s status as a master
element.

With these 4 features of Indesign, Masters, Paragraph Syles, Nested Documents
and Libraries, it is possible to create quite large Interaction Design documents.
The ability to add external documents and use Library elements means you can
change hundreds of things at once. With Masters you don’t have to waste time
designing every page and paragraph styles make it easy to change all the text at

once.
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Some Resources

An overview of InDesign CS3 Shortcuts:

http://www.nobledesktop.com/shortcuts-indesigncs3-mac.html

Joel Lauman’s Presentation on Wireframing:

http://www.slideshare.net/piksels/wireframes-and-interaction-design-documents-
presentation/

The what, when and why of wireframes:

http://userpathways.com/2008/06/26/the-what-when-and-why-of-wireframes/

InDesign for Interactive Design Wireframing

http://indesignsecrets.com/indesign-for-interactive-design-wireframing.php
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